
<!DOCTYPE html>

<!--[if lt IE 7]><html lang="en-US" class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" class="no-js"><!--<![endif]-->

	<head>

		<meta charset="utf-8">

		<!-- Google Chrome Frame for IE -->
		<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge" /><![endif]-->
		<!-- mobile meta -->
                    <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
        
		<link rel="shortcut icon" href="">

		<link rel="pingback" href="http://whus.org/xmlrpc.php">

		
		<!-- head functions -->
		<title>Talkin&#8217; True Hoops Podcast Episode 34: NBA Finals-J.R Smith&#8217;s All-Time Screw Up, LeBron&#8217;s Greatness, Warriors Dominance, Sixers Twitter Burner Accounts, and Ben Simmons Dating Kendall Jenner &#8211; WHUS Radio</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WHUS Radio &raquo; Feed" href="http://whus.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="WHUS Radio &raquo; Comments Feed" href="http://whus.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WHUS Radio &raquo; Talkin&#8217; True Hoops Podcast Episode 34: NBA Finals-J.R Smith&#8217;s All-Time Screw Up, LeBron&#8217;s Greatness, Warriors Dominance, Sixers Twitter Burner Accounts, and Ben Simmons Dating Kendall Jenner Comments Feed" href="http://whus.org/2018/06/talkin-true-hoops-podcast-episode-34-nba-finals-j-r-smiths-all-time-screw-up-lebrons-greatness-warriors-dominance-sixers-twitter-burner-accounts-and-ben-simmons-dating-kendall-jenner/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/whus.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=830e08a142ec08dc67791958aa1d3c98"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='login-with-ajax-css'  href='http://whus.org/wp-content/themes/valenti/plugins/login-with-ajax/widget.css?ver=3.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css'  href='http://whus.org/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css?ver=20170506' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-qtip-css'  href='http://whus.org/wp-content/plugins/google-calendar-events/assets/css/vendor/jquery.qtip.min.css?ver=3.1.14' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-grid-css'  href='http://whus.org/wp-content/plugins/google-calendar-events/assets/css/default-calendar-grid.min.css?ver=3.1.14' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-list-css'  href='http://whus.org/wp-content/plugins/google-calendar-events/assets/css/default-calendar-list.min.css?ver=3.1.14' type='text/css' media='all' />
<link rel='stylesheet' id='cb-main-stylesheet-css'  href='http://whus.org/wp-content/themes/valenti/library/css/style.css?ver=5.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='cb-font-stylesheet-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C700%2C400italic%7COpen+Sans%3A400%2C700%2C400italic&#038;subset=greek%2Cgreek-ext&#038;ver=5.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='http://whus.org/wp-content/themes/valenti/library/css/fontawesome/css/font-awesome.min.css?ver=4.3.0' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='cb-ie-only-css'  href='http://whus.org/wp-content/themes/valenti/library/css/ie.css?ver=5.1.3' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='cb-child-stylesheet-css'  href='http://whus.org/wp-content/themes/valenti-child/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://whus.org/wp-content/plugins/jetpack/css/jetpack.css?ver=6.1' type='text/css' media='all' />
<script type='text/javascript' src='http://whus.org/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://whus.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var LWA = {"ajaxurl":"http:\/\/whus.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://whus.org/wp-content/themes/valenti/plugins/login-with-ajax/login-with-ajax.js?ver=3.1.7'></script>
<script type='text/javascript' src='http://whus.org/wp-content/themes/valenti/library/js/modernizr.custom.min.js?ver=2.6.2'></script>
<link rel='https://api.w.org/' href='http://whus.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://whus.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://whus.org/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='The Hip Hop Enthusiast #42: New Albums From Nick Grant and Lil Baby, Ameer Vann Controversy, and Drake vs Pusa T' href='http://whus.org/2018/06/the-hip-hop-enthusiast-42-new-albums-from-nick-grant-and-lil-baby-ameer-vann-controversy-and-drake-vs-pusa-t/' />

<link rel="canonical" href="http://whus.org/2018/06/talkin-true-hoops-podcast-episode-34-nba-finals-j-r-smiths-all-time-screw-up-lebrons-greatness-warriors-dominance-sixers-twitter-burner-accounts-and-ben-simmons-dating-kendall-jenner/" />
<link rel='shortlink' href='https://wp.me/p5FmzO-29f5' />
<link rel="alternate" type="application/json+oembed" href="http://whus.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwhus.org%2F2018%2F06%2Ftalkin-true-hoops-podcast-episode-34-nba-finals-j-r-smiths-all-time-screw-up-lebrons-greatness-warriors-dominance-sixers-twitter-burner-accounts-and-ben-simmons-dating-kendall-jenner%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://whus.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwhus.org%2F2018%2F06%2Ftalkin-true-hoops-podcast-episode-34-nba-finals-j-r-smiths-all-time-screw-up-lebrons-greatness-warriors-dominance-sixers-twitter-burner-accounts-and-ben-simmons-dating-kendall-jenner%2F&#038;format=xml" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//whus.org/?wordfence_lh=1&hid=A6E93310B8B737904C38DA5FA291292A');
</script><script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>

<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><style>.cb-base-color, .cb-overlay-stars .fa-star, #cb-vote .fa-star, .cb-review-box .cb-score-box, .bbp-submit-wrapper button, .bbp-submit-wrapper button:visited, .buddypress .cb-cat-header #cb-cat-title a,  .buddypress .cb-cat-header #cb-cat-title a:visited, .woocommerce .star-rating:before, .woocommerce-page .star-rating:before, .woocommerce .star-rating span, .woocommerce-page .star-rating span, .woocommerce .stars a {
            color:#00b28c;
        }#cb-search-modal .cb-header, .cb-join-modal .cb-header, .lwa .cb-header, .cb-review-box .cb-score-box, .bbp-submit-wrapper button, #buddypress button:hover, #buddypress a.button:hover, #buddypress a.button:focus, #buddypress input[type=submit]:hover, #buddypress input[type=button]:hover, #buddypress input[type=reset]:hover, #buddypress ul.button-nav li a:hover, #buddypress ul.button-nav li.current a, #buddypress div.generic-button a:hover, #buddypress .comment-reply-link:hover, #buddypress .activity-list li.load-more:hover, #buddypress #groups-list .generic-button a:hover {
            border-color: #00b28c;
        }.cb-sidebar-widget .cb-sidebar-widget-title, .cb-multi-widget .tabbernav .tabberactive, .cb-author-page .cb-author-details .cb-meta .cb-author-page-contact, .cb-about-page .cb-author-line .cb-author-details .cb-meta .cb-author-page-contact, .cb-page-header, .cb-404-header, .cb-cat-header, #cb-footer #cb-widgets .cb-footer-widget-title span, #wp-calendar caption, .cb-tabs ul .current, #bbpress-forums li.bbp-header, #buddypress #members-list .cb-member-list-box .item .item-title, #buddypress div.item-list-tabs ul li.selected, #buddypress div.item-list-tabs ul li.current, #buddypress .item-list-tabs ul li:hover, .woocommerce div.product .woocommerce-tabs ul.tabs li.active {
            border-bottom-color: #00b28c ;
        }#cb-main-menu .current-post-ancestor, #cb-main-menu .current-menu-item, #cb-main-menu .current-menu-ancestor, #cb-main-menu .current-post-parent, #cb-main-menu .current-menu-parent, #cb-main-menu .current_page_item, #cb-main-menu .current-page-ancestor, #cb-main-menu .current-category-ancestor, .cb-review-box .cb-bar .cb-overlay span, #cb-accent-color, .cb-highlight, #buddypress button:hover, #buddypress a.button:hover, #buddypress a.button:focus, #buddypress input[type=submit]:hover, #buddypress input[type=button]:hover, #buddypress input[type=reset]:hover, #buddypress ul.button-nav li a:hover, #buddypress ul.button-nav li.current a, #buddypress div.generic-button a:hover, #buddypress .comment-reply-link:hover, #buddypress .activity-list li.load-more:hover, #buddypress #groups-list .generic-button a:hover {
            background-color: #00b28c;
        }</style><style type="text/css">
                                                 body, #respond { font-family: 'Open Sans', sans-serif; }
                                                 h1, h2, h3, h4, h5, h6, .h1, .h2, .h3, .h4, .h5, .h6, #cb-nav-bar #cb-main-menu ul li > a, .cb-author-posts-count, .cb-author-title, .cb-author-position, .search  .s, .cb-review-box .cb-bar, .cb-review-box .cb-score-box, .cb-review-box .cb-title, #cb-review-title, .cb-title-subtle, #cb-top-menu a, .tabbernav, #cb-next-link a, #cb-previous-link a, .cb-review-ext-box .cb-score, .tipper-positioner, .cb-caption, .cb-button, #wp-calendar caption, .forum-titles, .bbp-submit-wrapper button, #bbpress-forums li.bbp-header, #bbpress-forums fieldset.bbp-form .bbp-the-content-wrapper input, #bbpress-forums .bbp-forum-title, #bbpress-forums .bbp-topic-permalink, .widget_display_stats dl dt, .cb-lwa-profile .cb-block, #buddypress #members-list .cb-member-list-box .item .item-title, #buddypress div.item-list-tabs ul li, #buddypress .activity-list li.load-more, #buddypress a.activity-time-since, #buddypress ul#groups-list li div.meta, .widget.buddypress div.item-options, .cb-activity-stream #buddypress .activity-header .time-since, .cb-font-header, .woocommerce table.shop_table th, .woocommerce-page table.shop_table th, .cb-infinite-scroll a, .cb-no-more-posts { font-family:'Oswald', sans-serif; }
                     </style><style type="text/css">body {
  font-size: 15px;
  line-height: 1.5;
}.entry-content a, .entry-content a:visited {color:#00b28c; }body {color:#000000; }body { font-size: 16px; }@media only screen and (min-width: 1020px){ body { font-size: 17px; }}</style><!-- end custom css --><meta property="og:image" content="https://i0.wp.com/whus.org/wp-content/uploads/2018/05/Culture-Album-Edit.jpg?fit=1440%2C1481"><style>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</style>
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Talkin&#8217; True Hoops Podcast Episode 34: NBA Finals-J.R Smith&#8217;s All-Time Screw Up, LeBron&#8217;s Greatness, Warriors Dominance, Sixers Twitter Burner Accounts, and Ben Simmons Dating Kendall Jenner" />
<meta property="og:url" content="http://whus.org/2018/06/talkin-true-hoops-podcast-episode-34-nba-finals-j-r-smiths-all-time-screw-up-lebrons-greatness-warriors-dominance-sixers-twitter-burner-accounts-and-ben-simmons-dating-kendall-jenner/" />
<meta property="og:description" content="We are two games into the NBA Finals and we&#8217;ve got a ton to talk about! J.R makes a huge mistake, LeBron&#8217;s finals legacy, bad calls, and the Warriors greatness. We also dissect the Brya…" />
<meta property="article:published_time" content="2018-06-06T21:00:21+00:00" />
<meta property="article:modified_time" content="2018-06-06T17:32:38+00:00" />
<meta property="og:site_name" content="WHUS Radio" />
<meta property="og:image" content="https://i0.wp.com/whus.org/wp-content/uploads/2018/05/Culture-Album-Edit.jpg?fit=1167%2C1200" />
<meta property="og:image:width" content="1167" />
<meta property="og:image:height" content="1200" />
<meta property="og:locale" content="en_US" />

<!-- End Jetpack Open Graph Tags -->
<meta name="twitter:partner" content="tfwp" />
<meta name="twitter:card" content="summary" /><meta name="twitter:title" content="Talkin&#8217; True Hoops Podcast Episode 34: NBA Finals-J.R Smith&#8217;s All-Time Screw Up, LeBron&#8217;s Greatness, Warriors Dominance, Sixers Twitter Burner Accounts, and Ben Simmons Dating Kendall Jenner" /><meta name="twitter:description" content="We are two games into the NBA Finals and we&#039;ve got a ton to talk about! J.R makes a huge mistake, LeBron&#039;s finals legacy, bad calls, and the Warriors greatness. We also dissect the Bryan Colangelo Sixers Twitter burner accounts, Pistons coaching search, and much, much more! Be sure to subscribe and follow @talkintruehoops on&hellip;" />
			<style type="text/css" id="wp-custom-css">
				/*
Welcome to Custom CSS!

To learn how this works, see http://wp.me/PEmnE-Bt
*/
.container {
	position: relative;
	width: 100%;
	height: 0;
	padding-bottom: 56.25%;
}

.video {
	position: absolute;
	top: 0;
	left: 0;
	width: 100%;
	height: 100%;
}			</style>
				<!-- end head functions-->

	</head>

	<body class="post-template-default single single-post postid-512187 single-format-standard  cb-sticky-mm cb-sticky-sb-on cb-mod-underlines cb-mod-zoom cb-layout-fw cb-m-sticky cb-cat-t-dark cb-mobm-light cb-gs-style-a cb-modal-dark cb-light-blog cb-sidebar-right cb-fis-type-standard cb-fis-tl-st-default">

        
	    <div id="cb-outer-container">

            
            <!-- Small-Screen Menu -->
            
            <div id="cb-mob-menu" class="clearfix cb-light-menu">
                <a href="#" id="cb-mob-close" class="cb-link"><i class="fa cb-times"></i></a>

                                    <div class="cb-mob-menu-wrap">
                        <ul class="cb-small-nav"><li id="menu-item-505632" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505632"><a href="http://whus.org/music/">Music</a></li>
<li id="menu-item-505631" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505631"><a href="http://whus.org/news/">News</a></li>
<li id="menu-item-505630" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505630"><a href="http://whus.org/sports/">Sports</a></li>
<li id="menu-item-505629" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505629"><a href="http://whus.org/talk/">Talk</a></li>
<li id="menu-item-505628" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children cb-has-children menu-item-505628"><a href="http://whus.org/overview-2/">About</a>
<ul class="sub-menu">
	<li id="menu-item-3674" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3674"><a href="http://spinitron.com/radio/playlist.php?station=whus&#038;show=schedule">WHUS Schedule</a></li>
	<li id="menu-item-3675" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3675"><a href="http://spinitron.com/radio/playlist.php?station=whus2&#038;show=schedule">WHUS2 Schedule</a></li>
	<li id="menu-item-505635" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505635"><a href="http://whus.org/overview/">Overview</a></li>
	<li id="menu-item-505633" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505633"><a href="http://whus.org/overview-2/meet-the-team/">Meet the Team</a></li>
	<li id="menu-item-505636" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505636"><a href="http://whus.org/overview/training/">Training</a></li>
	<li id="menu-item-505634" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505634"><a href="http://whus.org/overview-2/psa/">Submit PSA</a></li>
	<li id="menu-item-505637" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505637"><a href="http://whus.org/donate/">Donate</a></li>
</ul>
</li>
<li id="menu-item-508012" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-508012"><a href="http://whus.org/overview/training/">Get Involved!</a></li>
</ul>                    </div>
                            </div>

            <!-- /Small-Screen Menu -->

        
    		<div id="cb-container" class="cb-unboxed clearfix" itemscope itemtype="http://schema.org/Article">

                <header class="header clearfix" role="banner">
                        
                        
                        <div id="cb-lwa" class=" cb-light-menu">
<div class="cb-login-modal cb-modal clearfix cb-light-menu">
    <div class="lwa lwa-default clearfix">
        <form class="lwa-form clearfix" action="http://whus.org/wp-login.php" method="post">

            <div class="cb-header">
                <div class="cb-title">Log In</div>
                <div class="cb-close"><span class="cb-close-modal cb-close-m"><i class="fa fa-times"></i></span></div>
            </div>

            <div class="cb-form-body">
                <div class="cb-username"><i class="fa fa-user"></i><input type="text" class="cb-form-input-username" name="log" placeholder="Username"></div>
                <div class="cb-password"><i class="fa fa-lock"></i><input type="password" name="pwd" placeholder="Password"></div>
                
                <div class="cb-submit">
                      <input type="submit" name="wp-submit" class="lwa_wp-submit" value="Log In" tabindex="100" />
                      <input type="hidden" name="lwa_profile_link" value="" />
                      <input type="hidden" name="login-with-ajax" value="login" />
                </div>
                <span class="lwa-status"></span>
                <div class="cb-lost-password">
                                          <a class="lwa-links-remember" href="http://whus.org/wp-login.php?action=lostpassword" title="Lost your password?">Lost your password?</a>
                                     </div>
                           </div>
        </form>

                <form class="lwa-remember clearfix" action="http://whus.org/wp-login.php?action=lostpassword" method="post" style="display:none;">
            <div class="cb-header">
                        <div class="cb-title">Lost your password?</div>
                        <div class="cb-close"><span class="cb-close-modal cb-close-m lwa-links-remember-cancel"><i class="fa fa-times"></i></span></div>
            </div>
            <div class="cb-form-body">
                <div class="cb-email">
                                                <i class="fa fa-envelope-o"></i><input type="text" name="user_login" class="lwa-user-remember" placeholder="Enter username or email">
                                          </div>
                 <div class="cb-remember-buttons">
                        <input type="submit" value="Get New Password" class="lwa-button-remember" />
                        <input type="hidden" name="login-with-ajax" value="remember" />
                 </div>
                 <span class="lwa-status"></span>
            </div>

        </form>
            </div>
</div>
</div><div id="cb-search-modal" class="cb-s-modal cb-modal cb-light-menu">
                        <div class="cb-search-box">
                            <div class="cb-header">
                                <div class="cb-title">Search</div>
                                <div class="cb-close">
                                    <span class="cb-close-modal cb-close-m"><i class="fa fa-times"></i></span>
                                </div>
                            </div><form role="search" method="get" class="cb-search" action="http://whus.org/">

    <input type="text" class="cb-search-field" placeholder="" value="" name="s" title="">
    <button class="cb-search-submit" type="submit" value=""><i class="fa fa-search"></i></button>

</form></div></div>
                        						
						<!--whus header replacement-->



						<div class="headcontainer">
	<div class="innerhead">
		<div class="whusheader">
	<img src="http://whus.org/wp-content/uploads/2015/01/whusheader.png" width="290" height="150" alt="header" usemap="#headermap">

	<map name="headermap">
		<area shape="rect" coords="20,5,275,145" href="http://whus.org" alt="whus">
	</map>
</div>

		<div class="whusheader2">
<img src="http://whus.org/wp-content/uploads/2015/01/whusplaylinks.png" width="360" height="150" alt="player links" usemap="#playerlinks">

<map name="playerlinks">
	<area shape="circle" coords="26,123,18" href="http://fm.whus.org" target="_blank" onclick="window.open(this.href, this.target, 'width=340,height=600,scrollbar=yes,location=no,menubar=no,titlebar=no,toolbar=no'); return false;" alt="play whus fm">
	<area shape="rect" coords="50,120,104,131" href="http://fm.whus.org" target="_blank" onclick="window.open(this.href, this.target, 'width=340,height=600,scrollbar=yes,location=no,menubar=no,titlebar=no,toolbar=no'); return false;" alt="play whus fm">
	<area shape="circle" coords="136,125,18" href="http://2.whus.org" target="_blank" onclick="window.open(this.href, this.target, 'width=340,height=600,scrollbar=yes,location=no,menubar=no,titlebar=no,toolbar=no'); return false;" alt="play whus2">
	<area shape="rect" coords="159,119,205,131" href="http://2.whus.org" target="_blank" onclick="window.open(this.href, this.target, 'width=340,height=600,scrollbar=yes,location=no,menubar=no,titlebar=no,toolbar=no'); return false;" alt="play whus2">
	<area shape="circle" coords="238,125,18" href="http://sports.whus.org" target="_blank" onclick="window.open(this.href, this.target, 'width=340,height=300,scrollbar=yes,location=no,menubar=no,titlebar=no,toolbar=no'); return false;" alt="play whus sports">
	<area shape="rect" coords="260,119,338,131" href="http://sports.whus.org" target="_blank" onclick="window.open(this.href, this.target, 'width=340,height=300,scrollbar=yes,location=no,menubar=no,titlebar=no,toolbar=no'); return false;" alt="play whus sports">
	</map>
		</div>
	</div>
</div>	
<div style="clear: both;"></div>
						<!-- End WHUS player links-->
						
                             <nav id="cb-nav-bar" class="clearfix cb-light-menu cb-full-width" role="navigation">
                                <div id="cb-main-menu" class="cb-nav-bar-wrap clearfix wrap">
                                    <ul class="nav main-nav wrap clearfix"><li id="menu-item-505618" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-505618"><a href="http://whus.org/">Home</a></li>
<li id="menu-item-505619" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505619"><a href="http://whus.org/music/">Music</a></li>
<li id="menu-item-3670" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children cb-has-children menu-item-3670"><a href="http://whus.org/category/news/local-news/">News</a><div class="cb-big-menu"><div class="cb-articles cb-with-sub cb-pre-load">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#00b28c;">Featured</span></div>
                                        <ul><li class="cb-article cb-relative cb-grid-entry cb-style-overlay clearfix"><div class="cb-mask" style="background-color:#00b28c;"><a href="http://whus.org/2016/03/play-bringing-awareness-to-the-sex-trafficking-industry-comes-to-the-student-union-theater/"><img width="480" height="240" src="https://i2.wp.com/whus.org/wp-content/uploads/2016/03/IMG_4172.jpg?resize=480%2C240" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt="" srcset="https://i2.wp.com/whus.org/wp-content/uploads/2016/03/IMG_4172.jpg?resize=480%2C240 480w, https://i2.wp.com/whus.org/wp-content/uploads/2016/03/IMG_4172.jpg?zoom=2&amp;resize=480%2C240 960w, https://i2.wp.com/whus.org/wp-content/uploads/2016/03/IMG_4172.jpg?zoom=3&amp;resize=480%2C240 1440w" sizes="(max-width: 480px) 100vw, 480px" /></a></div><div class="cb-meta cb-article-meta"><h2 class="cb-post-title"><a href="http://whus.org/2016/03/play-bringing-awareness-to-the-sex-trafficking-industry-comes-to-the-student-union-theater/">Play Bringing Awareness to the Sex Trafficking Industry Comes to the Student Union Theater</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="http://whus.org/author/newsdesk/">The News Desk</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2016-03-31">March 31, 2016</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder-o"></i>  <a href="http://whus.org/category/featured/" title="View all posts in Featured">Featured</a>,  <a href="http://whus.org/category/news/local-news/" title="View all posts in Local News">Local News</a>,  <a href="http://whus.org/category/news/" title="View all posts in News">News</a></div></div></div></li></ul>
                                     </div>
                                     <div class="cb-recent">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#00b28c;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix"><div class="cb-mask" style="background-color:#00b28c;"><a href="http://whus.org/2018/06/bicycle-talk-episode-101/"><img width="80" height="60" src="https://i0.wp.com/whus.org/wp-content/uploads/2017/10/fullsizeoutput_e15.jpeg?resize=80%2C60" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" srcset="https://i0.wp.com/whus.org/wp-content/uploads/2017/10/fullsizeoutput_e15.jpeg?resize=80%2C60 80w, https://i0.wp.com/whus.org/wp-content/uploads/2017/10/fullsizeoutput_e15.jpeg?zoom=2&amp;resize=80%2C60 160w, https://i0.wp.com/whus.org/wp-content/uploads/2017/10/fullsizeoutput_e15.jpeg?zoom=3&amp;resize=80%2C60 240w" sizes="(max-width: 80px) 100vw, 80px" /></a></div><div class="cb-meta"><h2 class="h4"><a href="http://whus.org/2018/06/bicycle-talk-episode-101/">Bicycle Talk Episode 101</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="http://whus.org/author/ronmanizza/">Ron Manizza</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-06-04">June 4, 2018</time></div></div></div></li> <li class="cb-article-2 clearfix"><div class="cb-mask" style="background-color:#00b28c;"><a href="http://whus.org/2018/05/uconn-communication-societys-5th-annual-public-speaking-competition/"><img width="80" height="60" src="https://i2.wp.com/whus.org/wp-content/uploads/2018/04/IMG_2596-1-e1524938316395.jpg?resize=80%2C60" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" srcset="https://i2.wp.com/whus.org/wp-content/uploads/2018/04/IMG_2596-1-e1524938316395.jpg?resize=80%2C60 80w, https://i2.wp.com/whus.org/wp-content/uploads/2018/04/IMG_2596-1-e1524938316395.jpg?zoom=2&amp;resize=80%2C60 160w, https://i2.wp.com/whus.org/wp-content/uploads/2018/04/IMG_2596-1-e1524938316395.jpg?zoom=3&amp;resize=80%2C60 240w" sizes="(max-width: 80px) 100vw, 80px" /></a></div><div class="cb-meta"><h2 class="h4"><a href="http://whus.org/2018/05/uconn-communication-societys-5th-annual-public-speaking-competition/">Uconn Communication Society&#8217;s 5th Annual Public Speaking Competition</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="http://whus.org/author/newsdesk/">The News Desk</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-05-07">May 7, 2018</time></div></div></div></li> <li class="cb-article-3 clearfix"><div class="cb-mask" style="background-color:#00b28c;"><a href="http://whus.org/2018/04/japanese-student-association-hosts-sakura-matsuri-festival-celebrating-spring/"><img width="80" height="60" src="https://i1.wp.com/whus.org/wp-content/uploads/2018/04/IMG_3878.jpg?resize=80%2C60" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt="" srcset="https://i1.wp.com/whus.org/wp-content/uploads/2018/04/IMG_3878.jpg?resize=80%2C60 80w, https://i1.wp.com/whus.org/wp-content/uploads/2018/04/IMG_3878.jpg?zoom=2&amp;resize=80%2C60 160w, https://i1.wp.com/whus.org/wp-content/uploads/2018/04/IMG_3878.jpg?zoom=3&amp;resize=80%2C60 240w" sizes="(max-width: 80px) 100vw, 80px" /></a></div><div class="cb-meta"><h2 class="h4"><a href="http://whus.org/2018/04/japanese-student-association-hosts-sakura-matsuri-festival-celebrating-spring/">Japanese Student Association Hosts Sakura Matsuri Festival Celebrating Spring</a></h2><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="http://whus.org/author/newsdesk/">The News Desk</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-04-28">April 28, 2018</time></div></div></div></li></ul>
                                     </div>
                                 </div><ul class="cb-sub-menu">	<li id="menu-item-3668" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3668"><a href="http://whus.org/category/news/local-news/" data-cb-c="22" class="cb-c-l">Local</a></li>
	<li id="menu-item-3667" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3667"><a href="http://whus.org/category/news/multimedia/" data-cb-c="23" class="cb-c-l">Multimedia</a></li>
	<li id="menu-item-3669" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3669"><a href="http://whus.org/category/news/headlines/" data-cb-c="20" class="cb-c-l">Headlines</a></li>
	<li id="menu-item-505638" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505638"><a href="http://whus.org/news/" data-cb-c="3684" class="cb-c-l">All News</a></li>
</ul></div></li>
<li id="menu-item-505620" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505620"><a href="http://whus.org/sports/">Sports</a></li>
<li id="menu-item-505622" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children cb-has-children menu-item-505622"><a href="http://whus.org/talk/">Talk</a><div class="cb-links-menu"><ul class="cb-sub-menu">	<li id="menu-item-508239" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-508239"><a href="http://whus.org/category/podcasts/radio-naturopath-podcast/" data-cb-c="1380" class="cb-c-l">Radio Naturopath</a></li>
	<li id="menu-item-508417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-508417"><a href="http://whus.org/category/podcasts/bicycle-talk/" data-cb-c="508417" class="cb-c-l">Bicycle Talk</a></li>
	<li id="menu-item-510319" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-510319"><a href="http://whus.org/category/podcasts/couchside-sports/" data-cb-c="2229" class="cb-c-l">CouchSide Sports</a></li>
	<li id="menu-item-510320" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-510320"><a href="http://whus.org/category/podcasts/the-hip-hop-enthusiast/" data-cb-c="2231" class="cb-c-l">The Hip Hop Enthusiast</a></li>
	<li id="menu-item-510321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-510321"><a href="http://whus.org/category/podcasts/darchive/" data-cb-c="2407" class="cb-c-l">d&#8217;Archive</a></li>
	<li id="menu-item-510322" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-510322"><a href="http://whus.org/category/podcasts/pcr-podcast-of-uconn-research-podcasts/" data-cb-c="2318" class="cb-c-l">PCR: Podcast of UConn Research</a></li>
	<li id="menu-item-508739" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-508739"><a href="http://whus.org/category/podcasts/professors-are-people-too/" data-cb-c="1740" class="cb-c-l">Professors Are People Too</a></li>
	<li id="menu-item-510323" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-510323"><a href="http://whus.org/category/podcasts/" data-cb-c="967" class="cb-c-l">All Podcasts</a></li>
</ul></div></li>
<li id="menu-item-510376" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children cb-has-children menu-item-510376"><a href="http://fm.whus.org">Listen</a><div class="cb-links-menu"><ul class="cb-sub-menu">	<li id="menu-item-3664" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3664"><a target="_blank" href="http://fm.whus.org/" data-cb-c="3664" class="cb-c-l">WHUS FM</a></li>
	<li id="menu-item-3665" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3665"><a target="_blank" href="http://2.whus.org/" data-cb-c="3665" class="cb-c-l">WHUS2</a></li>
	<li id="menu-item-508241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-508241"><a href="http://sports.whus.org" data-cb-c="508241" class="cb-c-l">WHUS Sports</a></li>
	<li id="menu-item-3662" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3662"><a target="_blank" href="http://spinitron.com/radio/playlist.php?station=whus&#038;show=schedule#here" data-cb-c="3662" class="cb-c-l">WHUS FM Schedule</a></li>
	<li id="menu-item-3663" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3663"><a target="_blank" href="http://spinitron.com/radio/playlist.php?station=whus2&#038;show=schedule#here" data-cb-c="3663" class="cb-c-l">WHUS2 Schedule</a></li>
	<li id="menu-item-508656" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-508656"><a href="http://whus.org/otto-music/" data-cb-c="508644" class="cb-c-l">Otto&#8217;s Music</a></li>
</ul></div></li>
<li id="menu-item-3666" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children cb-has-children menu-item-3666"><a href="http://whus.org/overview/">About</a><div class="cb-links-menu"><ul class="cb-sub-menu">	<li id="menu-item-505623" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505623"><a href="http://whus.org/overview/" data-cb-c="3681" class="cb-c-l">Overview</a></li>
	<li id="menu-item-505625" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505625"><a href="http://whus.org/overview-2/meet-the-team/" data-cb-c="3162" class="cb-c-l">Meet the Team</a></li>
	<li id="menu-item-505782" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505782"><a href="http://whus.org/donate/" data-cb-c="3678" class="cb-c-l">Donate</a></li>
	<li id="menu-item-505624" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505624"><a href="http://whus.org/overview/training/" data-cb-c="75" class="cb-c-l">Training</a></li>
	<li id="menu-item-505626" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505626"><a href="http://whus.org/overview-2/psa/" data-cb-c="188" class="cb-c-l">Submit PSA</a></li>
	<li id="menu-item-505639" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-505639"><a href="http://whus.org/governance/" data-cb-c="502966" class="cb-c-l">Governance</a></li>
</ul></div></li>
<li id="menu-item-508011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-508011"><a href="http://whus.org/overview/training/">Get Involved!</a></li>
<li class="cb-icons"><ul id="cb-icons-wrap"><li class="cb-icon-login cb-menu-icon"><a href="#" data-cb-tip="Login / Join" class="cb-tip-bot" id="cb-lwa-trigger"><i class="fa fa-user"></i></a></li><li class="cb-icon-search cb-menu-icon"><a href="#" data-cb-tip="Search" class="cb-tip-bot" id="cb-s-trigger"><i class="fa fa-search"></i></a></li></ul></li></ul>                                </div>
                            </nav>
                        
    	 				
                            <!-- Secondary Menu -->
                            <div id="cb-top-menu" class="clearfix cb-light-menu">
                                <div class="wrap cb-top-menu-wrap clearfix">
                                    
                                    <div class="cb-left-side cb-mob">
                                                                                    <a href="#" id="cb-mob-open"><i class="fa fa-bars"></i></a>
                                        <div class="cb-breaking-news cb-font-header"><span>WHUS News <i class="fa fa-long-arrow-right"></i></span><ul id="cb-ticker"><li><a href="http://whus.org/2018/06/bicycle-talk-episode-101/" title="Bicycle Talk Episode 101" >Bicycle Talk Episode 101</a> </li> <li><a href="http://whus.org/2018/05/talkin-true-hoops-podcast-episode-32-celtics-taking-control-over-cleveland-warriors-steal-a-game-from-houston-nba-draft-lottery-and-legal-sports-gambling/" title="Talkin&#8217; True Hoops Podcast Episode 32: Celtics Taking Control Over Cleveland, Warriors Steal a Game from Houston, NBA Draft Lottery, and Legal Sports Gambling" >Talkin&#8217; True Hoops Podcast Episode 32: Celtics Taking Control Over Cleveland, Warriors Steal a Game from Houston, NBA Draft Lottery, and Legal Sports Gambling</a> </li> <li><a href="http://whus.org/2018/05/uconn-communication-societys-5th-annual-public-speaking-competition/" title="Uconn Communication Society&#8217;s 5th Annual Public Speaking Competition" >Uconn Communication Society&#8217;s 5th Annual Public Speaking Competition</a> </li> <li><a href="http://whus.org/2018/04/japanese-student-association-hosts-sakura-matsuri-festival-celebrating-spring/" title="Japanese Student Association Hosts Sakura Matsuri Festival Celebrating Spring" >Japanese Student Association Hosts Sakura Matsuri Festival Celebrating Spring</a> </li> </ul></div></div><ul class="cb-top-nav"><li id="menu-item-54" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54"><a href="http://facebook.com/whusradio">Facebook</a></li>
<li id="menu-item-28" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28"><a href="http://twitter.com/whusradio">Twitter</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29"><a href="http://instagram.com/whusradio">Instagram</a></li>
</ul><div class="cb-mob-right"><a href="#" class="cb-small-menu-icons cb-small-menu-login" id="cb-lwa-trigger-sm"><i class="fa fa-user"></i></a><a href="#" title="Search" class="cb-tip-bot cb-small-menu-icons cb-small-menu-search" id="cb-s-trigger-sm"><i class="fa fa-search"></i></a></div>
                                </div>
                            </div>
                            <!-- /Secondary Menu -->

                        
                        
    	 				      <a href="#" id="cb-to-top" class="cb-base-color"><i class="fa fa-long-arrow-up"></i></a>

                        
			<!-- Google analytics tracking code-->
				<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-49876198-1', 'auto');
  ga('send', 'pageview');

</script>

 <!-- whus favicon begin-->

 <link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png?v=wAAplvwnvO">
<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png?v=wAAplvwnvO">
<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png?v=wAAplvwnvO">
<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png?v=wAAplvwnvO">
<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png?v=wAAplvwnvO">
<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png?v=wAAplvwnvO">
<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png?v=wAAplvwnvO">
<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png?v=wAAplvwnvO">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png?v=wAAplvwnvO">
<link rel="icon" type="image/png" href="/favicon-32x32.png?v=wAAplvwnvO" sizes="32x32">
<link rel="icon" type="image/png" href="/favicon-194x194.png?v=wAAplvwnvO" sizes="194x194">
<link rel="icon" type="image/png" href="/favicon-96x96.png?v=wAAplvwnvO" sizes="96x96">
<link rel="icon" type="image/png" href="/android-chrome-192x192.png?v=wAAplvwnvO" sizes="192x192">
<link rel="icon" type="image/png" href="/favicon-16x16.png?v=wAAplvwnvO" sizes="16x16">
<link rel="manifest" href="/manifest.json?v=wAAplvwnvO">
<link rel="mask-icon" href="/safari-pinned-tab.svg?v=wAAplvwnvO" color="#00b28c">
<link rel="shortcut icon" href="/favicon.ico?v=wAAplvwnvO">
<meta name="msapplication-TileColor" content="#da532c">
<meta name="msapplication-TileImage" content="/mstile-144x144.png?v=wAAplvwnvO">
<meta name="theme-color" content="#ffffff">

<!-- whus favicon end-->
						
                </header> <!-- end header -->            <div id="cb-content" class="wrap clearfix">

				   <div class="cb-breadcrumbs wrap"><a href="http://whus.org">Home</a><i class="fa fa-angle-right"></i><div itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://whus.org/category/talk/" title="View all posts in Talk" itemprop="url"><span itemprop="title">Talk</span></a><i class="fa fa-angle-right"></i><a href="http://whus.org/category/talk/entertainment/" title="View all posts in Entertainment" itemprop="url"><span itemprop="title">Entertainment</span></a></div></div>
					<div id="main" class="cb-main clearfix" role="main">

							<article id="post-512187" class="clearfix post-512187 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment category-featured category-sports category-talk category-talkin-true-hoops-podcast" role="article">

                                 <header id="cb-standard-featured"><div class="cb-mask"><img width="750" height="400" src="https://i0.wp.com/whus.org/wp-content/uploads/2018/05/Culture-Album-Edit.jpg?resize=750%2C400" class="cb-fi-standard wp-post-image" alt="" /></div><div id="cb-fis-wrap" class="cb-entry-header cb-fis cb-style-standard"><span class="cb-title-fi"><h1 class="entry-title cb-entry-title cb-single-title" itemprop="headline">Talkin&#8217; True Hoops Podcast Episode 34: NBA Finals-J.R Smith&#8217;s All-Time Screw Up, LeBron&#8217;s Greatness, Warriors Dominance, Sixers Twitter Burner Accounts, and Ben Simmons Dating Kendall Jenner</h1><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="http://whus.org/author/robertschlatter/">Robert Schlatter</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-06-06">June 6, 2018</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder-o"></i>  <a href="http://whus.org/category/talk/entertainment/" title="View all posts in Entertainment">Entertainment</a>,  <a href="http://whus.org/category/featured/" title="View all posts in Featured">Featured</a>,  <a href="http://whus.org/category/sports/" title="View all posts in Sports">Sports</a>,  <a href="http://whus.org/category/talk/" title="View all posts in Talk">Talk</a>,  <a href="http://whus.org/category/podcasts/talkin-true-hoops-podcast/" title="View all posts in Talkin&#039; True Hoops Podcast">Talkin' True Hoops Podcast</a></div></div></div></header>
								<section class="cb-entry-content entry-content clearfix" itemprop="articleBody">

									<!--powerpress_player--><div class="powerpress_player" id="powerpress_player_6615"><a href="http://5886e4ebcbc837d13f8e-597f4ed4ea6895a41e2bd2978eb66730.r56.cf5.rackcdn.com/talkn_tru_huups/Ep.34.mp3" title="Play" onclick="return powerpress_embed_html5a('6615','http://5886e4ebcbc837d13f8e-597f4ed4ea6895a41e2bd2978eb66730.r56.cf5.rackcdn.com/talkn_tru_huups/Ep.34.mp3');" target="_blank"><img src="https://i1.wp.com/whus.org/wp-content/plugins/powerpress/play_audio.png?resize=23%2C24" title="Play" alt="Play" style="border:0;" width="23 px" height="24 px" data-recalc-dims="1" /></a></div>
<p>We are two games into the NBA Finals and we&#8217;ve got a ton to talk about! J.R makes a huge mistake, LeBron&#8217;s finals legacy, bad calls, and the Warriors greatness. We also dissect the Bryan Colangelo Sixers Twitter burner accounts, Pistons coaching search, and much, much more! Be sure to subscribe and follow @talkintruehoops on Twitter and Instagram.</p>

								</section> <!-- end article section -->

								<footer class="article-footer">
									<div class="cb-social-sharing cb-post-footer-block cb-beside cb-social-box clearfix"><div class="cb-title-subtle">Share On:</div><div id="fb-root"></div> <script>(function(d, s, id) {var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.0"; fjs.parentNode.insertBefore(js, fjs); }(document, "script", "facebook-jssdk"));</script><div class="cb-facebook"><div class="fb-like" data-href="http://whus.org/2018/06/talkin-true-hoops-podcast-episode-34-nba-finals-j-r-smiths-all-time-screw-up-lebrons-greatness-warriors-dominance-sixers-twitter-burner-accounts-and-ben-simmons-dating-kendall-jenner/" data-layout="box_count" data-action="like" data-show-faces="false" data-share="false"></div></div><div class="cb-pinterest"><script type="text/javascript" src="//assets.pinterest.com/js/pinit.js" async></script>
            <a href="//pinterest.com/pin/create/button/?url=http%3A%2F%2Fwhus.org%2F2018%2F06%2Ftalkin-true-hoops-podcast-episode-34-nba-finals-j-r-smiths-all-time-screw-up-lebrons-greatness-warriors-dominance-sixers-twitter-burner-accounts-and-ben-simmons-dating-kendall-jenner%2F&media=https%3A%2F%2Fi0.wp.com%2Fwhus.org%2Fwp-content%2Fuploads%2F2018%2F05%2FCulture-Album-Edit.jpg%3Ffit%3D1440%252C1481&description=Talkin%26%238217%3B+True+Hoops+Podcast+Episode+34%3A+NBA+Finals-J.R+Smith%26%238217%3Bs+All-Time+Screw+Up%2C+LeBron%26%238217%3Bs+Greatness%2C+Warriors+Dominance%2C+Sixers+Twitter+Burner+Accounts%2C+and+Ben+Simmons+Dating+Kendall+Jenner" data-pin-do="buttonPin" data-pin-config="above" target="_blank"><img src="//assets.pinterest.com/images/pidgets/pin_it_button.png" /></a></div><div class="cb-google cb-tall">
                            <div class="g-plusone" data-size="tall"></div>

                            <script type="text/javascript">
                              (function() {
                                var po = document.createElement("script"); po.type = "text/javascript"; po.async = true;
                                po.src = "https://apis.google.com/js/plusone.js";
                                var s = document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(po, s);
                              })();
                            </script></div><div class="cb-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-dnt="true"  data-count="vertical">Tweet</a><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div><su:badge layout="5"></su:badge>
                            <script type="text/javascript">
                              (function() {
                                var li = document.createElement("script"); li.type = "text/javascript"; li.async = true;
                                li.src = ("https:" == document.location.protocol ? "https:" : "http:") + "//platform.stumbleupon.com/1/widgets.js";
                                var s = document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(li, s);
                              })();
                            </script></div><div id="cb-previous-next-links" class="cb-post-footer-block clearfix"><div id="cb-previous-link"><a href="http://whus.org/2018/06/the-hip-hop-enthusiast-42-new-albums-from-nick-grant-and-lil-baby-ameer-vann-controversy-and-drake-vs-pusa-t/"><i class="fa fa-long-arrow-left"></i></a><a href="http://whus.org/2018/06/the-hip-hop-enthusiast-42-new-albums-from-nick-grant-and-lil-baby-ameer-vann-controversy-and-drake-vs-pusa-t/" rel="prev">The Hip Hop Enthusiast #42: New Albums From Nick Grant and Lil Baby, Ameer Vann Controversy, and Drake vs Pusa T</a></div><div class="cb-empty">No More Stories</div></div><div id="cb-author-box" class="clearfix"><h3 class="cb-block-title">About The Author</h3><div class="cb-mask"><a href="http://whus.org/author/robertschlatter/"><img alt='' src='http://2.gravatar.com/avatar/e39ec291f4512ba95c569144e76835cf?s=120&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/e39ec291f4512ba95c569144e76835cf?s=240&#038;d=mm&#038;r=g 2x' class='avatar avatar-120 photo' height='120' width='120' /></a></div><div class="cb-meta"><div class="cb-info"><div class="cb-author-title vcard" itemprop="author"><a href="http://whus.org/author/robertschlatter/"><span class="fn">Robert Schlatter</span></a></div><div class="cb-author-contact"><a href="mailto:robschlatter@sbcglobal.net"><i class="fa fa-envelope-o cb-tip-bot" data-cb-tip="Email"></i></a> <a href="https://itunes.apple.com/us/podcast/talkin-true-hoops-podcast/id1309384820?mt=2" target="_blank"><i class="fa fa-link cb-tip-bot" data-cb-tip="Website"></i></a>  <a href="https://plus.google.com/u/0/108550299486718616272?rel=author" rel="publisher" target="_top" data-cb-tip="Google+" class="cb-googleplus cb-tip-bot" ><img src="//ssl.gstatic.com/images/icons/gplus-16.png" data-at2x="//ssl.gstatic.com/images/icons/gplus-32.png" alt="Google+"></a></div></div><p class="cb-author-bio">I am sophomore at the University of Connecticut majoring in Digital Media and Design. I have been involved with WHUS for the past year and a half producing/creating the Talkin' True Hoops Podcast.</p></div></div><div id="cb-related-posts" class="cb-related-posts-block cb-post-end-block clearfix"><h3 class="cb-block-title">Related Posts</h3><ul>                            <li class="cb-style-overlay cb-grid-entry cb-related-post no-1">
                                <div class="cb-mask" style="background-color:#00b28c;"><a href="http://whus.org/2018/06/the-hip-hop-enthusiast-42-new-albums-from-nick-grant-and-lil-baby-ameer-vann-controversy-and-drake-vs-pusa-t/"><img width="360" height="240" src="https://i1.wp.com/whus.org/wp-content/uploads/2018/04/Hip-Hop-Logo-1.png?resize=360%2C240" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://i1.wp.com/whus.org/wp-content/uploads/2018/04/Hip-Hop-Logo-1.png?resize=360%2C240 360w, https://i1.wp.com/whus.org/wp-content/uploads/2018/04/Hip-Hop-Logo-1.png?resize=600%2C400 600w, https://i1.wp.com/whus.org/wp-content/uploads/2018/04/Hip-Hop-Logo-1.png?zoom=2&amp;resize=360%2C240 720w, https://i1.wp.com/whus.org/wp-content/uploads/2018/04/Hip-Hop-Logo-1.png?zoom=3&amp;resize=360%2C240 1080w" sizes="(max-width: 360px) 100vw, 360px" /></a></div>
                                 <div class="cb-meta cb-article-meta">
                                     <h4 class="h3 cb-post-title"><a href="http://whus.org/2018/06/the-hip-hop-enthusiast-42-new-albums-from-nick-grant-and-lil-baby-ameer-vann-controversy-and-drake-vs-pusa-t/">The Hip Hop Enthusiast #42: New Albums From Nick Grant and Lil Baby, Ameer Vann Controversy, and Drake vs Pusa T</a></h4>
                                     <div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="http://whus.org/author/kylefrench/">Kyle French</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-06-04">June 4, 2018</time></div></div>                                </div>
                            </li>
                            <li class="cb-style-overlay cb-grid-entry cb-related-post no-2">
                                <div class="cb-mask" style="background-color:#00b28c;"><a href="http://whus.org/2018/06/radio-naturopath-episode-172-interview-with-gerald-berkowitz-ph-d-cannabinoids-in-horticulture/"><img width="360" height="240" src="https://i0.wp.com/whus.org/wp-content/uploads/2016/04/Radio-Naturopath-Podcast-Image-01.png?resize=360%2C240" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://i0.wp.com/whus.org/wp-content/uploads/2016/04/Radio-Naturopath-Podcast-Image-01.png?resize=360%2C240 360w, https://i0.wp.com/whus.org/wp-content/uploads/2016/04/Radio-Naturopath-Podcast-Image-01.png?resize=600%2C400 600w, https://i0.wp.com/whus.org/wp-content/uploads/2016/04/Radio-Naturopath-Podcast-Image-01.png?zoom=2&amp;resize=360%2C240 720w, https://i0.wp.com/whus.org/wp-content/uploads/2016/04/Radio-Naturopath-Podcast-Image-01.png?zoom=3&amp;resize=360%2C240 1080w" sizes="(max-width: 360px) 100vw, 360px" /></a></div>
                                 <div class="cb-meta cb-article-meta">
                                     <h4 class="h3 cb-post-title"><a href="http://whus.org/2018/06/radio-naturopath-episode-172-interview-with-gerald-berkowitz-ph-d-cannabinoids-in-horticulture/">Radio Naturopath Episode 172: Interview with Gerald Berkowitz, Ph.D: Cannabinoids in Horticulture</a></h4>
                                     <div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="http://whus.org/author/radionaturopath/">RadioNaturopath</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-06-04">June 4, 2018</time></div></div>                                </div>
                            </li>
</ul></div>
								</footer> <!-- end article footer -->

								



	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/06/talkin-true-hoops-podcast-episode-34-nba-finals-j-r-smiths-all-time-screw-up-lebrons-greatness-warriors-dominance-sixers-twitter-burner-accounts-and-ben-simmons-dating-kendall-jenner/#respond" style="display:none;">Cancel Reply</a></small></h3>			<form action="http://whus.org/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name<span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email<span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='512187' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="f77b13befe" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="163"/></p>			</form>
			</div><!-- #respond -->
	
							</article> <!-- end article -->

						
						
					</div> <!-- end #main -->

					<div class="cb-sticky-sidebar"><aside class="cb-sidebar clearfix" role="complementary">

<div id="search-2" class="cb-sidebar-widget widget_search"><form role="search" method="get" class="cb-search" action="http://whus.org/">

    <input type="text" class="cb-search-field" placeholder="" value="" name="s" title="">
    <button class="cb-search-submit" type="submit" value=""><i class="fa fa-search"></i></button>

</form></div><div id="social-media-icons-5" class="cb-sidebar-widget cb-social-media-widget clearfix"><a href="http://www.twitter.com/whusradio" target="_blank" class="cb-social-media-icon cb-twitter icon-1"></a><a href="http://www.facebook.com/whusradio" target="_blank" class="cb-social-media-icon cb-facebook icon-2"></a><a href="https://plus.google.com/110843522727315969119/about" target="_blank" class="cb-social-media-icon cb-googleplus icon-3"></a><a href="http://youtube.com/whusradio917" target="_blank" class="cb-social-media-icon cb-youtube icon-4"></a></div><div id="cb-recent-posts-slider-2" class="cb-sidebar-widget widget-latest-articles-slider"><h3 class="cb-sidebar-widget-title">Latest</h3>		<div class="flexslider-widget">
		<ul class="slides">
		    
		            <li class="cb-article clearfix"  style="border-top-color:#00b28c;">
            	
               <div class="cb-mask"><a href="http://whus.org/2018/06/talkin-true-hoops-podcast-episode-34-nba-finals-j-r-smiths-all-time-screw-up-lebrons-greatness-warriors-dominance-sixers-twitter-burner-accounts-and-ben-simmons-dating-kendall-jenner/"><img width="1440" height="1481" src="http://whus.org/wp-content/uploads/2018/05/Culture-Album-Edit.jpg" class="attachment-cb-430-270 size-cb-430-270 wp-post-image" alt="" srcset="https://i0.wp.com/whus.org/wp-content/uploads/2018/05/Culture-Album-Edit.jpg?w=1440 1440w, https://i0.wp.com/whus.org/wp-content/uploads/2018/05/Culture-Album-Edit.jpg?resize=292%2C300 292w, https://i0.wp.com/whus.org/wp-content/uploads/2018/05/Culture-Album-Edit.jpg?resize=768%2C790 768w, https://i0.wp.com/whus.org/wp-content/uploads/2018/05/Culture-Album-Edit.jpg?resize=996%2C1024 996w" sizes="(max-width: 1440px) 100vw, 1440px" /></a></div>
                        
                <div class="cb-meta">
                         <h4><a href="http://whus.org/2018/06/talkin-true-hoops-podcast-episode-34-nba-finals-j-r-smiths-all-time-screw-up-lebrons-greatness-warriors-dominance-sixers-twitter-burner-accounts-and-ben-simmons-dating-kendall-jenner/">Talkin&#8217; True Hoops Podcast Episode 34: NBA Finals-J.R Smith&#8217;s All-Time Screw Up, LeBron&#8217;s Greatness, Warriors Dominance, Sixers Twitter Burner Accounts, and Ben Simmons Dating Kendall Jenner</a></h4>
                         <div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="http://whus.org/author/robertschlatter/">Robert Schlatter</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-06-06">June 6, 2018</time></div></div>                </div>
       
                                
            </li>
		            <li class="cb-article clearfix"  style="border-top-color:#00b28c;">
            	
               <div class="cb-mask"><a href="http://whus.org/2018/06/the-hip-hop-enthusiast-42-new-albums-from-nick-grant-and-lil-baby-ameer-vann-controversy-and-drake-vs-pusa-t/"><img width="1400" height="1400" src="http://whus.org/wp-content/uploads/2018/04/Hip-Hop-Logo-1.png" class="attachment-cb-430-270 size-cb-430-270 wp-post-image" alt="" srcset="https://i1.wp.com/whus.org/wp-content/uploads/2018/04/Hip-Hop-Logo-1.png?w=1400 1400w, https://i1.wp.com/whus.org/wp-content/uploads/2018/04/Hip-Hop-Logo-1.png?resize=150%2C150 150w, https://i1.wp.com/whus.org/wp-content/uploads/2018/04/Hip-Hop-Logo-1.png?resize=300%2C300 300w, https://i1.wp.com/whus.org/wp-content/uploads/2018/04/Hip-Hop-Logo-1.png?resize=768%2C768 768w, https://i1.wp.com/whus.org/wp-content/uploads/2018/04/Hip-Hop-Logo-1.png?resize=1024%2C1024 1024w, https://i1.wp.com/whus.org/wp-content/uploads/2018/04/Hip-Hop-Logo-1.png?resize=125%2C125 125w" sizes="(max-width: 1400px) 100vw, 1400px" /></a></div>
                        
                <div class="cb-meta">
                         <h4><a href="http://whus.org/2018/06/the-hip-hop-enthusiast-42-new-albums-from-nick-grant-and-lil-baby-ameer-vann-controversy-and-drake-vs-pusa-t/">The Hip Hop Enthusiast #42: New Albums From Nick Grant and Lil Baby, Ameer Vann Controversy, and Drake vs Pusa T</a></h4>
                         <div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="http://whus.org/author/kylefrench/">Kyle French</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-06-04">June 4, 2018</time></div></div>                </div>
       
                                
            </li>
		            <li class="cb-article clearfix"  style="border-top-color:#00b28c;">
            	
               <div class="cb-mask"><a href="http://whus.org/2018/06/radio-naturopath-episode-172-interview-with-gerald-berkowitz-ph-d-cannabinoids-in-horticulture/"><img width="3000" height="3000" src="http://whus.org/wp-content/uploads/2016/04/Radio-Naturopath-Podcast-Image-01.png" class="attachment-cb-430-270 size-cb-430-270 wp-post-image" alt="" srcset="https://i0.wp.com/whus.org/wp-content/uploads/2016/04/Radio-Naturopath-Podcast-Image-01.png?w=3000 3000w, https://i0.wp.com/whus.org/wp-content/uploads/2016/04/Radio-Naturopath-Podcast-Image-01.png?resize=150%2C150 150w, https://i0.wp.com/whus.org/wp-content/uploads/2016/04/Radio-Naturopath-Podcast-Image-01.png?resize=300%2C300 300w, https://i0.wp.com/whus.org/wp-content/uploads/2016/04/Radio-Naturopath-Podcast-Image-01.png?resize=768%2C768 768w, https://i0.wp.com/whus.org/wp-content/uploads/2016/04/Radio-Naturopath-Podcast-Image-01.png?resize=1024%2C1024 1024w, https://i0.wp.com/whus.org/wp-content/uploads/2016/04/Radio-Naturopath-Podcast-Image-01.png?resize=125%2C125 125w, https://i0.wp.com/whus.org/wp-content/uploads/2016/04/Radio-Naturopath-Podcast-Image-01.png?w=1500 1500w, https://i0.wp.com/whus.org/wp-content/uploads/2016/04/Radio-Naturopath-Podcast-Image-01.png?w=2250 2250w" sizes="(max-width: 3000px) 100vw, 3000px" /></a></div>
                        
                <div class="cb-meta">
                         <h4><a href="http://whus.org/2018/06/radio-naturopath-episode-172-interview-with-gerald-berkowitz-ph-d-cannabinoids-in-horticulture/">Radio Naturopath Episode 172: Interview with Gerald Berkowitz, Ph.D: Cannabinoids in Horticulture</a></h4>
                         <div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="http://whus.org/author/radionaturopath/">RadioNaturopath</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-06-04">June 4, 2018</time></div></div>                </div>
       
                                
            </li>
				</ul>
		</div>
		</div>		<div id="recent-posts-2" class="cb-sidebar-widget widget_recent_entries">		<h3 class="cb-sidebar-widget-title">Recent Posts</h3>		<ul>
											<li>
					<a href="http://whus.org/2018/06/talkin-true-hoops-podcast-episode-34-nba-finals-j-r-smiths-all-time-screw-up-lebrons-greatness-warriors-dominance-sixers-twitter-burner-accounts-and-ben-simmons-dating-kendall-jenner/">Talkin&#8217; True Hoops Podcast Episode 34: NBA Finals-J.R Smith&#8217;s All-Time Screw Up, LeBron&#8217;s Greatness, Warriors Dominance, Sixers Twitter Burner Accounts, and Ben Simmons Dating Kendall Jenner</a>
									</li>
											<li>
					<a href="http://whus.org/2018/06/the-hip-hop-enthusiast-42-new-albums-from-nick-grant-and-lil-baby-ameer-vann-controversy-and-drake-vs-pusa-t/">The Hip Hop Enthusiast #42: New Albums From Nick Grant and Lil Baby, Ameer Vann Controversy, and Drake vs Pusa T</a>
									</li>
											<li>
					<a href="http://whus.org/2018/06/radio-naturopath-episode-172-interview-with-gerald-berkowitz-ph-d-cannabinoids-in-horticulture/">Radio Naturopath Episode 172: Interview with Gerald Berkowitz, Ph.D: Cannabinoids in Horticulture</a>
									</li>
											<li>
					<a href="http://whus.org/2018/06/bicycle-talk-episode-101/">Bicycle Talk Episode 101</a>
									</li>
											<li>
					<a href="http://whus.org/2018/06/bicycle-talk-episode-100/">Bicycle Talk  Episode 100</a>
									</li>
											<li>
					<a href="http://whus.org/2018/06/bicycle-talk-episode-98/">Bicycle Talk  Episode 98</a>
									</li>
											<li>
					<a href="http://whus.org/2018/06/bicycle-talk-episode-99/">Bicycle Talk Episode 99</a>
									</li>
											<li>
					<a href="http://whus.org/2018/05/talkin-true-hoops-podcast-episode-33-nba-finals-warriors-vs-cavaliers-preview-interview-with-carmelo-anthony-kyle-korver-beef-creator-and-all-nba-teams-released/">Talkin&#8217; True Hoops Podcast Episode 33: NBA Finals Warriors vs Cavaliers Preview, Interview with Carmelo Anthony/Kyle Korver Beef Creator, and ALL-NBA Teams Released</a>
									</li>
											<li>
					<a href="http://whus.org/2018/05/the-hip-hop-enthusiast-41-playboi-carti-and-tee-grizzley-albums-j-cole-and-lil-pump-sit-down/">The Hip Hop Enthusiast #41: Playboi Carti and Tee Grizzley albums, J Cole and Lil Pump Sit Down</a>
									</li>
											<li>
					<a href="http://whus.org/2018/05/radio-naturopath-episode-171-naturopathic-principles-the-healing-power-of-nature-chia-seeds-flax-seeds/">Radio Naturopath Episode 171: Naturopathic Principles: The Healing Power of Nature, Chia Seeds, Flax Seeds</a>
									</li>
					</ul>
		</div><div id="tag_cloud-2" class="cb-sidebar-widget widget_tag_cloud"><h3 class="cb-sidebar-widget-title">Categories</h3><div class="tagcloud"><a href="http://whus.org/category/music/album-review/" class="tag-cloud-link tag-link-14 tag-link-position-1" style="font-size: 11.888888888889pt;" aria-label="Album Review (75 items)">Album Review<span class="tag-link-count"> (75)</span></a>
<a href="http://whus.org/category/music/albums-you-might-hear-this-week/" class="tag-cloud-link tag-link-15 tag-link-position-2" style="font-size: 8.3333333333333pt;" aria-label="Albums You Might Hear This Week (35 items)">Albums You Might Hear This Week<span class="tag-link-count"> (35)</span></a>
<a href="http://whus.org/category/announcements/" class="tag-cloud-link tag-link-2 tag-link-position-3" style="font-size: 8pt;" aria-label="Announcements (33 items)">Announcements<span class="tag-link-count"> (33)</span></a>
<a href="http://whus.org/category/podcasts/bicycle-talk/" class="tag-cloud-link tag-link-1411 tag-link-position-4" style="font-size: 13.222222222222pt;" aria-label="Bicycle Talk (98 items)">Bicycle Talk<span class="tag-link-count"> (98)</span></a>
<a href="http://whus.org/category/music/concert-reviews/" class="tag-cloud-link tag-link-16 tag-link-position-5" style="font-size: 9.3333333333333pt;" aria-label="Concert Reviews (44 items)">Concert Reviews<span class="tag-link-count"> (44)</span></a>
<a href="http://whus.org/category/music/concerts/" class="tag-cloud-link tag-link-17 tag-link-position-6" style="font-size: 8.1111111111111pt;" aria-label="Concerts (34 items)">Concerts<span class="tag-link-count"> (34)</span></a>
<a href="http://whus.org/category/talk/entertainment/" class="tag-cloud-link tag-link-18 tag-link-position-7" style="font-size: 13.777777777778pt;" aria-label="Entertainment (112 items)">Entertainment<span class="tag-link-count"> (112)</span></a>
<a href="http://whus.org/category/featured/" class="tag-cloud-link tag-link-3 tag-link-position-8" style="font-size: 19.666666666667pt;" aria-label="Featured (375 items)">Featured<span class="tag-link-count"> (375)</span></a>
<a href="http://whus.org/category/news/headlines/" class="tag-cloud-link tag-link-20 tag-link-position-9" style="font-size: 17.666666666667pt;" aria-label="Headlines (248 items)">Headlines<span class="tag-link-count"> (248)</span></a>
<a href="http://whus.org/category/talk/health-and-science/" class="tag-cloud-link tag-link-21 tag-link-position-10" style="font-size: 18.111111111111pt;" aria-label="Health and Science (273 items)">Health and Science<span class="tag-link-count"> (273)</span></a>
<a href="http://whus.org/category/news/local-news/" class="tag-cloud-link tag-link-22 tag-link-position-11" style="font-size: 16.777777777778pt;" aria-label="Local News (207 items)">Local News<span class="tag-link-count"> (207)</span></a>
<a href="http://whus.org/category/music/" class="tag-cloud-link tag-link-4 tag-link-position-12" style="font-size: 16.222222222222pt;" aria-label="Music (184 items)">Music<span class="tag-link-count"> (184)</span></a>
<a href="http://whus.org/category/news/" class="tag-cloud-link tag-link-6 tag-link-position-13" style="font-size: 20.222222222222pt;" aria-label="News (429 items)">News<span class="tag-link-count"> (429)</span></a>
<a href="http://whus.org/category/podcasts/" class="tag-cloud-link tag-link-967 tag-link-position-14" style="font-size: 19.222222222222pt;" aria-label="Podcasts (346 items)">Podcasts<span class="tag-link-count"> (346)</span></a>
<a href="http://whus.org/category/talk/public-affairs/" class="tag-cloud-link tag-link-24 tag-link-position-15" style="font-size: 19.222222222222pt;" aria-label="Public Affairs (345 items)">Public Affairs<span class="tag-link-count"> (345)</span></a>
<a href="http://whus.org/category/podcasts/radio-naturopath-podcast/" class="tag-cloud-link tag-link-1380 tag-link-position-16" style="font-size: 13.111111111111pt;" aria-label="Radio Naturopath (96 items)">Radio Naturopath<span class="tag-link-count"> (96)</span></a>
<a href="http://whus.org/category/sports/" class="tag-cloud-link tag-link-25 tag-link-position-17" style="font-size: 11.888888888889pt;" aria-label="Sports (75 items)">Sports<span class="tag-link-count"> (75)</span></a>
<a href="http://whus.org/category/talk/" class="tag-cloud-link tag-link-12 tag-link-position-18" style="font-size: 22pt;" aria-label="Talk (620 items)">Talk<span class="tag-link-count"> (620)</span></a>
<a href="http://whus.org/category/podcasts/the-hip-hop-enthusiast/" class="tag-cloud-link tag-link-2231 tag-link-position-19" style="font-size: 9.1111111111111pt;" aria-label="The Hip Hop Enthusiast (42 items)">The Hip Hop Enthusiast<span class="tag-link-count"> (42)</span></a>
<a href="http://whus.org/category/uncategorized/" class="tag-cloud-link tag-link-1 tag-link-position-20" style="font-size: 9.3333333333333pt;" aria-label="Uncategorized (44 items)">Uncategorized<span class="tag-link-count"> (44)</span></a></div>
</div>
</aside>

</div>
			</div> <!-- end #cb-content -->

     			<footer id="cb-footer" class="" role="contentinfo">

    				<div id="cb-widgets" class="cb-footer-a cb-footer-wrap wrap clearfix cb-fw">

                                                    <div class="cb-one cb-column clearfix">
                                <div id="text-5" class="cb-footer-widget widget_text"><h3 class="cb-footer-widget-title"><span>Studio Line: 860 486 9487</span></h3>			<div class="textwidget"></div>
		</div>                            </div>
                                                                            <div class="cb-two cb-column clearfix">
                                <div id="text-9" class="cb-footer-widget widget_text"><h3 class="cb-footer-widget-title"><span>Comments: feedback@whus.org</span></h3>			<div class="textwidget"></div>
		</div>                            </div>
                                                                            <div class="cb-three cb-column clearfix">
                                <div id="text-10" class="cb-footer-widget widget_text">			<div class="textwidget"><p><a href="https://publicfiles.fcc.gov/fm-profile/whus/">Public File</a></p>
</div>
		</div>                            </div>
                                                
                    </div>

                    
                        <div class="cb-footer-lower clearfix">

                            <div class="wrap clearfix">

                                <div class="cb-copyright">  
© WHUS Radio 2110 Hillside Road, Storrs, CT 06269       860 486 9487</div>

        						
           					</div>

        				</div>
    				
    			</footer> <!-- end footer -->

    		</div> <!-- end #cb-container -->

		</div> <!-- end #cb-outer-container -->

        <span id="cb-overlay"></span>

			<div style="display:none">
	<div class="grofile-hash-map-e39ec291f4512ba95c569144e76835cf">
	</div>
	</div>
<script type='text/javascript' src='http://whus.org/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201823'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2018Junaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://whus.org/wp-content/plugins/jetpack/modules/wpgroho.js?ver=830e08a142ec08dc67791958aa1d3c98'></script>
<script type='text/javascript' src='http://whus.org/wp-content/plugins/jetpack/_inc/build/twitter-timeline.min.js?ver=4.0.0'></script>
<script type='text/javascript' src='http://whus.org/wp-content/plugins/google-calendar-events/assets/js/vendor/jquery.qtip.min.js?ver=3.1.14'></script>
<script type='text/javascript' src='http://whus.org/wp-content/plugins/google-calendar-events/assets/js/vendor/moment.min.js?ver=3.1.14'></script>
<script type='text/javascript' src='http://whus.org/wp-content/plugins/google-calendar-events/assets/js/vendor/moment-timezone-with-data.min.js?ver=3.1.14'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var simcal_default_calendar = {"ajax_url":"\/wp-admin\/admin-ajax.php","nonce":"99028873fd","locale":"en_US","text_dir":"ltr","months":{"full":["January","February","March","April","May","June","July","August","September","October","November","December"],"short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"]},"days":{"full":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]},"meridiem":{"AM":"AM","am":"am","PM":"PM","pm":"pm"}};
var simcal_default_calendar = {"ajax_url":"\/wp-admin\/admin-ajax.php","nonce":"99028873fd","locale":"en_US","text_dir":"ltr","months":{"full":["January","February","March","April","May","June","July","August","September","October","November","December"],"short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"]},"days":{"full":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]},"meridiem":{"AM":"AM","am":"am","PM":"PM","pm":"pm"}};
/* ]]> */
</script>
<script type='text/javascript' src='http://whus.org/wp-content/plugins/google-calendar-events/assets/js/default-calendar.min.js?ver=3.1.14'></script>
<script type='text/javascript' src='http://whus.org/wp-includes/js/comment-reply.min.js?ver=830e08a142ec08dc67791958aa1d3c98'></script>
<script type='text/javascript' src='http://whus.org/wp-content/themes/valenti/library/js/cookie.min.js?ver=5.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cbExt = {"cbSS":"on","cbLb":"on"};
/* ]]> */
</script>
<script type='text/javascript' src='http://whus.org/wp-content/themes/valenti/library/js/jquery.ext.js?ver=5.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cbScripts = {"cbUrl":"http:\/\/whus.org\/wp-admin\/admin-ajax.php","cbPostID":"512187","cbSlider":["600",true,"7000"]};
/* ]]> */
</script>
<script type='text/javascript' src='http://whus.org/wp-content/themes/valenti/library/js/cb-scripts.min.js?ver=5.1.3'></script>
<script type='text/javascript' src='http://whus.org/wp-content/plugins/google-calendar-events/assets/js/vendor/imagesloaded.pkgd.min.js?ver=3.1.14'></script>
<script type='text/javascript' src='http://whus.org/wp-includes/js/wp-embed.min.js?ver=830e08a142ec08dc67791958aa1d3c98'></script>
<script type='text/javascript' src='http://whus.org/wp-content/plugins/powerpress/player.min.js?ver=830e08a142ec08dc67791958aa1d3c98'></script>
<script async="async" type='text/javascript' src='http://whus.org/wp-content/plugins/akismet/_inc/form.js?ver=4.0.3'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201823.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.1',blog:'83739916',post:'512187',tz:'-4',srv:'whus.org'} ]);
	_stq.push([ 'clickTrackerInit', '83739916', '512187' ]);
</script>

	</body>

</html> <!-- The End. what a ride! -->